Whenever a page on your site doesn't load, an error message will be displayed to the site visitor. Since there are different errors, there are different pages which will appear, but what's common for all of them is that they're generic and almost certainly shall have nothing that resembles the design of your Internet site, which may be frustrating for any visitor. This is the reason why hosting providers have introduced a function known as Custom Error Pages. For a variety of different errors, website visitors will see your customized content, which could be informative or funny, depending on your personal preference, and which shall match the overall design of your site, so the pages won't seem like they're not part of your Internet site at all. You can use this option for many errors - 400 (Bad request), 401 (Unauthorized), 403 (Forbidden) and 404 (File not Found).

Custom Error Pages in Web Hosting

When you get a Linux web hosting package from us, you shall be able to set custom made error pages for your websites fast and easy, as this feature is part of all of our solutions. Once you've created the files and uploaded them to your website hosting account, you should check out the Hosted Domains section of your Hepsia Control Panel and click on the Edit button for the specific domain or subdomain. In the pop-up that will appear, you'll see drop-down menus for all 4 types of errors and for each one of them you could pick an Apache default page, a generic page from our system or a tailor-made page. If you pick the third option, you should only input the URL to the file that you have uploaded and save the change. One other way to set custom error pages is to set up an .htaccess file in the domain or subdomain folder and to add several lines of program code in it. In case you don't have prior experience or if you are simply uncertain how to do that, you may simply copy and paste the code from our Knowledge Base article on that topic.

Custom Error Pages in Semi-dedicated Hosting

When you host your websites in a semi-dedicated server account with our company, you can set customized error pages for any of them easily via our custom Hepsia hosting Control Panel. With only a couple of clicks inside the Hosted Domains section, you'll be able to edit the default setting from a system page to a customized one for any of the 4 error types. All you need to do is supply a link to each and every file that you've uploaded before that and then save the change. If required, you'll be able to revert this customization at any time and in exactly the same way. If you would like, you may use an .htaccess file as well. It should be created/uploaded within the domain or subdomain folder associated with the site whose error pages you would want to alter and the content for this sort of file can be found in our Help article for this matter.